爱易网
IT新闻
IT新闻
爱易资讯
网站搭建
云虚拟主机教程
云服务器教程
Apache教程
IIS教程
Nginx教程
网站策划
站长文章
推广教程
淘宝客教程
网页设计
HTML教程
XHTML教程
CSS教程
HTML5教程
CSS3教程
JavaSript基础
JQuery教程
Node.js教程
前端技术
Ajax教程
Js特效
Xml教程
平面设计
页面UI设计
photoshop教程
程序开发
AI人工智能
Asp教程
Php教程
Asp.Net教程
Net Core教程
C#教程
Java教程
Jsp教程
开发技术
微信小程序教程
Uniapp开发教程
微信公众号开发
Andriod教程
IOS教程
DOS教程
Python教程
Docker教程
Windows Container教程
数据库
MSSQL教程
MySQL教程
Redis教程
Access教程
Oracle教程
数据库教程
操作系统
Linux教程
Windows教程
MAC教程
Cisco教程
交换机教程
防火墙教程
搜索
爱易网页
Linux
Linux服务器NFS配备
Linux服务器NFS配备
日期:2014-05-16 浏览次数:21226 次
Linux服务器NFS配置
iiiiii
1 楼 loveExtJs 2011-03-17
一、 Linux服务器NFS配置
说明:在介绍配置之前,假设服务端的IP地址为10.27.208.237,客户端的IP地址为10.27.208.218,以此来举例说明
? 服务端的配置
1. 修改服务端配置文件
#vi /etc/exports
设置格式为:Directory hostname (options),其中Directory为需要共享的目录、hostname为客户机的域名/IP地址/IP地址段;也可以为空,空则代表任
意主机、options 可选,如不指定,则采用默认选项。如ro,rw,sync,async等。如:
/home/llg/videotool 10.27.208.218 (rw,async,no_root_squash)
/home/llg/videotool是共享的目录,10.27.208.218这个IP地址是允许访问共享文件的主机地址(需要说明的是,服务器的IP要和需要链接访问的主机IP地
址是同一网段的,要能保持两者ping的通,否则将不能链接)、rw指定客户机的权限为可读可写、Async;同步,服务端只有接受到客户端的回应,才进行
下一步,以确保连接更可靠、No_root_squash;不压缩root用户的权限,如要更安全请用roo_squash。同时,此配置文件中也可设置多台客户机的访问,如
:
/home/llg/videotool 10.27.208.218 (rw,async,no_root_squash)
/home/llg/temp 10.27.208.217 (rw,async,no_root_squash)
/home/llg/test 10.27.208.216 (rw,async,no_root_squash)
2. 修改hosts.deny配置文件
#vi /etc/hosts.deny
在此配置文件的里面添加如下配置:
portmap:ALL
lockd:ALL
mountd:ALL
rquotad:ALL
statd:ALL
3. 修改hosts.allow配置文件
#vi /etc/hosts.allow
在文件中添加如下配置:
portmap: 10.27.208.218
lockd: 10.27.208.218
mountd: 10.27.208.218
rquotad: 10.27.208.218
statd: 10.27.208.218
(10.27.208.218这个IP为上面设置的客户机IP地址)
4. 重启服务器
#reboot
5. 启动NFS服务程序
#service portmap start
#service nfsserver start
6. 查看共享的目录是否已经生效
#exportfs –i
7. 查看NFS服务进程是否已经启动
#rpcinfo –p
其中,2049为NFS的服务进程,111为portmap的,如果这两个进程已经启动,那么服务端的配置就已经完成了。
? 客户端的配置
1. 首先启动portmap服务程序
#service portmap start
2. 创建临时挂载目录,如:
#mkdir /home/llg/mnt
3. 将服务端的共享的目录挂载到本地的目录当中去,如:
# mount -t nfs 10.27.208.237:/home/llg/videotool /home/llg/mnt
其中10.27.208.237为服务器的IP地址
/home/llg/videotool为服务端共享的目录
/home/llg/mnt为客户机本地的目录
配置完成。
上一篇:Ubuntu 24.04磁盘挂载数据盘
下一篇: linux重要系统服务
免责声明:
本文仅代表作者个人观点,与爱易网无关。其原创性以及文中陈述文字和内容未经本站证实,对本文以及其中全部或者部分内容、文字的真实性、完整性、及时性本站不作任何保证或承诺,请读者仅作参考,并请自行核实相关内容。
相关资料
更多>
linux停avr单片机开发:中断服务程序
Ubuntu 上安装nrpe 出错
linux下email发布出去,发邮件需要什么权限?怎样设置?解决方案
剖解linux启动过程(转)
linux上Apache+PHP+MySQL安装配置攻略
Linux内存储器管理
RedHat Enterprise Linux 5.0之VPN服务器简易筹建
linux那些事情
如此使用宏定义第一回见!解决思路
推荐阅读
更多>
加载静态库失败,该怎么解决
求一份适合模仿学习的ftp客户端代码,该如何处理
Linux上tomcat安装
PHP100精粹:很靠谱linux常用命令
比较流行的开源的SIP客户端软件都有哪些?该如何解决
经过gc和linux脚本监控内存,防止内存溢出(java.lang.OutOfMemoryErr)
linux:secureCRT方向键ABCD有关问题的解决
fopen函数返回NULL,打印errno值为0,perror打印结果为Error 零,fopen失败原因是什么
linux 输入ifconfig不显示解决方案
Linux/Unix版,精华贴分门别类汇总
命令明明在哪儿,可是便是找不到,这是什么情况
关于安装两个gcc的版本变换有关问题
关于linux挂载点 /mnt /media解决办法
linux惯用的操作指令
见见这4个sed命令
Linux下简单配置安装cacti(六)snmp再次安装
linux系统停修改权限
LInux停的串口通信
怎样用u盘安装ubuntu下linux11.04系统?解决方案
Linux装配JDK详细步骤(绿色安装)